Back to overview
Downtime

Disruption to LeasePilot service

Apr 25 at 01:17pm EDT
Affected services
LeasePilot App

Resolved
Apr 25 at 02:43pm EDT

Root Cause:
The disruption was traced back to a combination of increased transaction volume and resource constraints in our database infrastructure. These factors led to excessive locking and delays in processing requests.

Resolution:
The PlanetScale support team provisioned new database replicas and increased resource allocation to stabilize the service. We also adjusted our backup schedule to reduce frequency and improve performance.

Future Mitigation:
We will review our database schema and workload to optimize performance and prevent similar issues. Additionally, we will continue monitoring our system closely to ensure stability and reliability.

We apologize for any inconvenience caused and appreciate your understanding and patience as we worked to resolve this issue. Please reach out to our support team if you have any further questions or concerns.

Created
Apr 25 at 01:17pm EDT

LeasePilot is experiencing a service disruption affecting user access to our application. This was due to an unexpected increase in replication lag between database replicas, which impacted our ability to process transactions efficiently.