Back to overview
Downtime

Microsoft Azure Front Door Outage Impacting LeasePilot Access

Oct 29 at 11:49am EDT
Affected services
LeasePilot App

Resolved
Oct 29 at 12:56pm EDT

πŸš‘ Incident Timeline

  • Monitoring detected loss of incoming traffic
  • Engineering team alerted via BetterStack
  • Identified issue as Azure Front Door outage
  • Service restored and confirmed operational

πŸ”§ Actions Taken During the Incident

Our engineering team worked to restore access while monitoring Azure’s service recovery. We implemented temporary mitigations to reestablish connectivity and continued to monitor the platform until full recovery was confirmed.

Created
Oct 29 at 11:49am EDT

πŸ”₯ Incident Description

Between 7:43 AM HDT and 8:37 AM HDT on October 29, 2025, users were unable to access the LeasePilot platform due to an outage affecting Microsoft Azure Front Door, our primary content delivery and traffic routing service.

πŸ•΅οΈβ€β™‚οΈ Root Cause

The incident was caused by a widespread Microsoft Azure Front Door outage, which disrupted normal routing of requests to our infrastructure.

πŸ› οΈ Immediate Impact

Systems affected: Production App, APIs
Users affected: All customers
Functionality degraded: Full outage β€” users were unable to access the LeasePilot platform or any hosted services.